Clicky

Skocz do zawartości


Zdjęcie
- - - - -

Problem z wyświetlaniem strony w Kohana

3 odpowiedzi w tym temacie
kohana problme view

  • Zaloguj się, aby dodać odpowiedź

#1 vilanim

vilanim

    Początkujący

  • Użytkownik
  • Pip
  • 2 postów

Napisano 18 lipiec 2014 - 09:17

WItam.

Mam problem z wyświetlaniem strony w Kohana po przeniesieniu jej z innego serwera.

Po wpisaniu adresu url wyswietla mi następujące błędy:

SYSPATH\classes\kohana\view.php [ 252 ]

247 	 */
248 	public function set_filename($file)
249 	{
250 		if (($path = Kohana::find_file('views', $file)) === FALSE)
251 		{
252 			throw new Kohana_View_Exception('The requested view :file could not be found', array(
253 				':file' => $file,
254 			));
255 		}
256 
257 		// Store the file path locally



SYSPATH\classes\kohana\view.php [ 137 ] » Kohana_View->set_filename(arguments)

132 	 */
133 	public function __construct($file = NULL, array $data = NULL)
134 	{
135 		if ($file !== NULL)
136 		{
137 			$this->set_filename($file);
138 		}
139 
140 		if ($data !== NULL)
141 		{
142 			// Add the values to the current data




SYSPATH\classes\kohana\view.php [ 30 ] » Kohana_View->__construct(arguments)

25 	 * @param   array   array of values
26 	 * @return  View
27 	 */
28 	public static function factory($file = NULL, array $data = NULL)
29 	{
30 		return new View($file, $data);
31 	}
32 
33 	/**
34 	 * Captures the output that is generated when a view is included.
35 	 * The view data will be extracted to make local variables. This method




APPPATH\bootstrap.php [ 120 ] » Kohana_View::factory(arguments)

115         $request->status = 404;
116         echo View::factory('layout')
117             ->set('title', 'HATO - 404')
118             ->set('sidebar', View::factory('sidebar'))
119             ->set('content', View::factory('page/404'))
120             ->set('forum', View::factory('forum'))
121             ->render();
122     }
123 
124     if ($request->send_headers())
125     {




DOCROOT\index.php [ 109 ] » require(arguments)

104 	// Load empty core extension
105 	require SYSPATH.'classes/kohana'.EXT;
106 }
107 
108 // Bootstrap the application
109 require APPPATH.'bootstrap'.EXT;


Czy mógłbym prosić o wytłumaczenie mi o co chodzi bo przyznam się szczerze, że nie ograniam tematu. ;(

Bedę wdzięczny za pomoc.

Pozdrawiam!



#2 nrm

nrm

    webmastah

  • Admin
  • 1106 postów
  • Skąd:Katowice

Napisano 18 lipiec 2014 - 10:07

brak jakiegoś widoku?



#3 vilanim

vilanim

    Początkujący

  • Użytkownik
  • Pip
  • 2 postów

Napisano 18 lipiec 2014 - 10:15

wywnioskowałem, że brakuje mu jakiegoś widoku - forum.php...

tam prawdopodobnie są treści, ale za nic nie mogę wymyslić gdzie, co i jak...

pierwszy raz mam do czynienia z tym frameworkiem ;(



#4 Anioł

Anioł

    Początkujący

  • Użytkownik
  • Pip
  • 2 postów

Napisano 24 lipiec 2014 - 11:46

na początek sprawdz konfiguracje - bootstrap.php / base_url







Również z jednym lub większą ilością słów kluczowych: kohana, problme, view

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych