Clicky

Skocz do zawartości


Zdjęcie
* * * * * 1 głosy

[3.3] Route:url ErrorException [ Warning ]: preg_replace_callback()

5 odpowiedzi w tym temacie

  • Zaloguj się, aby dodać odpowiedź

#1 junior89

junior89

    Początkujący

  • Użytkownik
  • Pip
  • 32 postów

Napisano 02 kwiecień 2014 - 08:11

Robie w widoku link do dodawania nowego języka w taki sposób

<a class="btn btn-sm btn-success" href="<?= Route::url('settings', array('controller' => 'language', 'action' => 'new')); ?>">

Na lokalnym serwerze nie mam blędy, jednak po wgraniu na serwer pojawia mi się taki bląd

http://prntscr.com/36adcv

ErrorException [ Warning ]: preg_replace_callback(): Requires argument 2, '', to be a valid callback

 

Gdy usunę ten link z widoku to błąd się nie pojawia, próbowałem to naprawić jednak bez skutku.

 

Ktoś miał podobny problem?

 

Z głory dzieki.

 

 



#2 Maciek

Maciek

    Senior Mastah

  • Użytkownik
  • PipPipPip
  • 780 postów

Napisano 02 kwiecień 2014 - 10:38

Nie podałeś chyba najważniejszego, czyli tego co kryje się pod $portion - czy jest to string (nazwa funkcji), array (metoda statyczna lub metoda obiektu), czy funkcja anonimowa?


  • thejw23 lubi to

#3 Zepco

Zepco

    Senior Mastah

  • Moderator
  • 1583 postów
  • Skąd:Kielce

Napisano 02 kwiecień 2014 - 21:07

Jak masz zdefiniowany routing 'settings'?

I jakie masz wersje PHP na obu serwerach?


OŚWIADCZENIE: Ja, niżej podpisany, świadomy wszystkich konsekwencji tego posta postanawiam go dopuścić do użytku publicznego, albowiem bo gdyż aczkolwiek uważam, że nie wyrządzi on (znaczy: post) krzywdy nikomu innemu niźli mnie samemu (czyli autorowi posta).
-- Zepco --


#4 junior89

junior89

    Początkujący

  • Użytkownik
  • Pip
  • 32 postów

Napisano 02 kwiecień 2014 - 22:53

Routing 'settings':

Route::set('settings', 'backend/settings(/<controller>(/<action>(/<id>)))')
        ->defaults(array(
            'directory' => 'Backend/Settings',
            'controller' => 'Base',
            'action' => 'index',
        ));

Wersja PHP na lokalu to: 5.5.9 a na linuxpl 5.4.15.

 

Chciałem zmianić ale 5.4.15 jest najnowsza na linuxpl.com.

 

Czy w tym jest problem?



#5 Zepco

Zepco

    Senior Mastah

  • Moderator
  • 1583 postów
  • Skąd:Kielce

Napisano 03 kwiecień 2014 - 05:59

A masz możliwość wybrania niższej wersji PHP ale tak, żeby to było minimum 5.3?

Niby wszystkie parametry dla tej funkcji są spełnione, bo dostaje funkcję anonimową, więc podejrzewałbym problem z samym interpreterem.


OŚWIADCZENIE: Ja, niżej podpisany, świadomy wszystkich konsekwencji tego posta postanawiam go dopuścić do użytku publicznego, albowiem bo gdyż aczkolwiek uważam, że nie wyrządzi on (znaczy: post) krzywdy nikomu innemu niźli mnie samemu (czyli autorowi posta).
-- Zepco --


#6 junior89

junior89

    Początkujący

  • Użytkownik
  • Pip
  • 32 postów

Napisano 03 kwiecień 2014 - 08:14

Zmieniłem na wersje 5.3.25 i działa.

Dzięki za podpowiedź.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych